The Daily Click ::. Forums ::. Klik Coding Help ::. Memory Usage
 

Post Reply  Post Oekaki 
 

Posted By Message

UrbanMonk

BRING BACK MITCH

Registered
  07/07/2008
Points
  50102

Has Donated, Thank You!Little Pirate!ARGH SignKliktober Special Award TagPicture Me This Round 33 Winner!The Outlaw!VIP MemberHasslevania 2!I am an April FoolKitty
Picture Me This Round 32 Winner!Picture Me This Round 42 Winner!Picture Me This Round 44 Winner!Picture Me This Round 53 Winner!
26th May, 2009 at 03:58:45 -

It's kinda funny that I was just talking about this on another topic, and now I'm having a problem with it
Anyway, its not exactly the same thing though.

My program only has one frame, with a bunch( 8 ) of subapps. A subapp passes data to a global variable then restarts the frame. Because when the frame is restarted, the global values are still saved, but on every restart the amount of memory being used jumps by 50mbs or more. Soon the application is taking about 900mbs of memory. I've tried deleting all of the memory sucking objects before restarts, and that helps a little (it only jumps 10mbs), but something else is still holding on the memory addresses even after deleting all of the objects, and then it keeps those addresses after a restart. Not good.

I'm starting to think a extension I'm using has a memory leak. Anyway, thanks for all the help in advance!

Edited by UrbanMonk

 
n/a

nim



Registered
  17/05/2002
Points
  7229
26th May, 2009 at 04:40:34 -

8 subapps! Why so many? Do you work for NASA?

 
//

UrbanMonk

BRING BACK MITCH

Registered
  07/07/2008
Points
  50102

Has Donated, Thank You!Little Pirate!ARGH SignKliktober Special Award TagPicture Me This Round 33 Winner!The Outlaw!VIP MemberHasslevania 2!I am an April FoolKitty
Picture Me This Round 32 Winner!Picture Me This Round 42 Winner!Picture Me This Round 44 Winner!Picture Me This Round 53 Winner!
26th May, 2009 at 04:55:46 -

No I don't use mmf2 for my NASA job.

I'm thinking that I might have to remove extensions one by one to check which is killing the memory usage.

 
n/a

nim



Registered
  17/05/2002
Points
  7229
26th May, 2009 at 05:30:23 -

I'm not sure which would be easier - your suggestion or this: how about not restarting the frame, and just resetting all values and active positions instead?

 
//

UrbanMonk

BRING BACK MITCH

Registered
  07/07/2008
Points
  50102

Has Donated, Thank You!Little Pirate!ARGH SignKliktober Special Award TagPicture Me This Round 33 Winner!The Outlaw!VIP MemberHasslevania 2!I am an April FoolKitty
Picture Me This Round 32 Winner!Picture Me This Round 42 Winner!Picture Me This Round 44 Winner!Picture Me This Round 53 Winner!
26th May, 2009 at 05:43:20 -

hmmm. sounds like a plan.

EDIT: It's working so far! but I'd still like to know what extension is giving me trouble for future reference.

Edited by UrbanMonk

 
n/a

Silveraura

God's God

Registered
  08/08/2002
Points
  6747

Game of the Week WinnerKlikCast StarAlien In Training!VIP Member360 OwnerWii OwnerSonic SpeedThe Cake is a LieComputerChristmas Tree!
I am an April Fool
26th May, 2009 at 16:13:38 -

Rather then restarting the frame, just use "Go to frame" and click on that same frame. It work's like a restart frame, but doesn't goof up ram.

 
http://www.facebook.com/truediamondgame

UrbanMonk

BRING BACK MITCH

Registered
  07/07/2008
Points
  50102

Has Donated, Thank You!Little Pirate!ARGH SignKliktober Special Award TagPicture Me This Round 33 Winner!The Outlaw!VIP MemberHasslevania 2!I am an April FoolKitty
Picture Me This Round 32 Winner!Picture Me This Round 42 Winner!Picture Me This Round 44 Winner!Picture Me This Round 53 Winner!
26th May, 2009 at 21:39:11 -

...

I wish I would have been told that before I started converting everything.
It worked like a charm, in fact the memory usage dropped after jumping to the same frame.

Thanks BrandonC!

 
n/a

UrbanMonk

BRING BACK MITCH

Registered
  07/07/2008
Points
  50102

Has Donated, Thank You!Little Pirate!ARGH SignKliktober Special Award TagPicture Me This Round 33 Winner!The Outlaw!VIP MemberHasslevania 2!I am an April FoolKitty
Picture Me This Round 32 Winner!Picture Me This Round 42 Winner!Picture Me This Round 44 Winner!Picture Me This Round 53 Winner!
27th May, 2009 at 02:34:48 -

Ok the problem hasn't been totally solved yet, but I did figure out what was eating my memory, the subapps (but of course) When I have the "Create at the start of the frame" checked each subapp eats about 10mbs apiece, I might have to figure out another way to do everything besides using subapps.

Unless someone here knows something I don't

Thanks

 
n/a

UF Comtec



Registered
  13/06/2002
Points
  300
27th May, 2009 at 09:44:57 -

hehe arent you though flood horse!?

 
n/a
   

Post Reply



 



Advertisement

Worth A Click