The Daily Click ::. Forums ::. Klik Coding Help ::. Performance differences
 

Post Reply  Post Oekaki 
 

Posted By Message

Dr. James MD

Addict

Registered
  08/12/2003
Points
  11941

First GOTW AwardSecond GOTW AwardThird GOTW AwardPicture Me This -Round 26- Winner!
13th June, 2009 at 22:02:56 -

I have 2 computers, one is a 3 year old 2ghz C2D and the other is a newer 6 month old 2ghz C2D. I don't know the names of the chips but I know that the newer C2D runs games better than the older chip. Thats agiven. Everything about the newer C2D machine is better than the old one (except it has 1/3 less ram at 2gb).

So. Why don't (HWA-less) MMF2 games run well on it?!

I thought I'd test my game on my laptop (better display) but it runs at 40fps compared to 60 on the older C2D. It's on every frame too! Even the basic referal frames with no objects and 3 lines of code. Switching to 256 colours doesn't change anything.
What could be causing this substantial slowdown? Is there a magic value in the registry somewhere that says "make MMF2 games run normal"?

 
Image
http://uk.youtube.com/watch?v=j--8iXVv2_U
On the sixth day God created Manchester
"You gotta get that sand out your vaj!" x13
www.bossbaddie.com

OMC

What a goofball

Registered
  21/05/2007
Points
  3309

KlikCast Musician! Guy with a HatSomewhat CrazyARGH SignLikes TDCHas Donated, Thank You!Retired Admin
13th June, 2009 at 22:10:10 -

Assuming these are both running the same operating system, it very well could be that little RAM difference.

The older C2D is faster, even if older, and it might have a larger FSB. (or a smaller one but doesn't affect the performance like the extra Ghz does)

 

  		
  		

MrPineapple

the fruitiest word i know

Registered
  14/10/2008
Points
  1470

VIP Member
13th June, 2009 at 22:11:50 -

you probably should have thought of doing this earlier

btw, i'm willing to bet the older C2D has a lot less cache!

Edited by MrPineapple

 
i am STILL a talking pineapple!

Dr. James MD

Addict

Registered
  08/12/2003
Points
  11941

First GOTW AwardSecond GOTW AwardThird GOTW AwardPicture Me This -Round 26- Winner!
13th June, 2009 at 22:35:38 -

Just downloaded CPU-Z on both systems. Old is a 2ghz Merom, 4096kb l2 cache, 665mhz FSB. New is a 2ghz Penryn, 3072kb L2 cache, 1061mhz FSB.

Also tested the game on an identical spec iMac to the one I've been developing on and thats fine too. It just seems to be the Penryn after all :S.

 
Image
http://uk.youtube.com/watch?v=j--8iXVv2_U
On the sixth day God created Manchester
"You gotta get that sand out your vaj!" x13
www.bossbaddie.com

OMC

What a goofball

Registered
  21/05/2007
Points
  3309

KlikCast Musician! Guy with a HatSomewhat CrazyARGH SignLikes TDCHas Donated, Thank You!Retired Admin
13th June, 2009 at 22:39:42 -

Straunje. I've had weird inconsistencies like that too, but I think that was just system config usually. It reminds me of the fact that the active-heavy Splotches title screen ran better in TGF1 than MMF2 on my old desktop, and yet not on my new laptop. O_o

Edited by OMC

 

  		
  		

Dr. James MD

Addict

Registered
  08/12/2003
Points
  11941

First GOTW AwardSecond GOTW AwardThird GOTW AwardPicture Me This -Round 26- Winner!
13th June, 2009 at 22:41:50 -

You only deepen the mystery .
But yea other games are perfect. I can run L4D's effect (CPU) setting on high on the Penryn compared to low on the Merom for the same FPS. I'll just do a format. When in doubt; format!

Edit: reinstalled the original drivers and it seems to be good now. Must have been some faulty 2D driver hack in there.

Edited by Dr. James MD

 
Image
http://uk.youtube.com/watch?v=j--8iXVv2_U
On the sixth day God created Manchester
"You gotta get that sand out your vaj!" x13
www.bossbaddie.com

OMC

What a goofball

Registered
  21/05/2007
Points
  3309

KlikCast Musician! Guy with a HatSomewhat CrazyARGH SignLikes TDCHas Donated, Thank You!Retired Admin
13th June, 2009 at 23:13:52 -

Glad it worked out.

 

  		
  		
   

Post Reply



 



Advertisement

Worth A Click