The Daily Click ::. Forums ::. Klik Coding Help ::. Framerate stutters! WTF is wrong?!
 

Post Reply  Post Oekaki 
 

Posted By Message

Blue66



Registered
  24/05/2008
Points
  1186

GOTW JUNE 2010 WINNER!Hero of TimeVIP Member
8th October, 2011 at 16:51:27 -

Hi guys!

I've always appreciated your help and this time I seriously hope that someone can tell me WTF is going on with my game.

I'm currently using latest MMF2 HWA Dev beta 252, before that the 251 official HWA version. Win7, Intel i7 and Nvidia 560Ti (just tech info so that you see it's impossible that my hardware can't handle my game).

What's the problem:
My framerate has random drops. I don't know why. It happens at a random time (usually after about 2minutes have passed at one frame but sometimes right from the beginning) and the frame rate starts to stutter while the screen scrolls (maybe even when it's standing still but that's too hard to see). The game runs at 60 fps but even if I turn it up to 200, the framerate noticably drops and the game seems to freeze up for a fraction of a second over a period of time like every 2 seconds. After another period of time, the issue disappears until I reset the frame or leave to another frame. Then the same thing happens again.

I have about 1200 global events and almost every object only uses events when it's currently visible to the player and if it's not on screen, it won't activate the events to save performance. When I stand around, no objects get created or anything unless it happens on screen. I have an average of 120 objects and still this performance stutter occurs.

My attempts to fix it:
At first, I thought it's the window control object, because that's a totally new thing to me. I removed it entirely from the game and all events, but still the random framerate stuttering appears. Then I've tried ALL events in the whole game and turned them off. No effect. I've started removing background layers but still the random stutter appears when the screen scrolls. I've tried turning V-Sync off or machine independant speed, but that makes the problem worse.

I don't know what causes this problem. My last hope will be installing an older version of my graphic card driver or something. But before I go totally insane, maybe some1 here has a solution that I haven't tried before.

Every help you can give is greatly appreciated!

 
www.paulinthenet.de
www.gungirl2.com

Blue66



Registered
  24/05/2008
Points
  1186

GOTW JUNE 2010 WINNER!Hero of TimeVIP Member
9th October, 2011 at 12:21:56 -

I've made an example.

It has only the most basic events (move left / right, scroll screen) and still I have random frame skips.

Take a look:
http://www.gungirl2.com/stuff/FrameSkipTest.mfa
(if it wants to save as .tiff just rename it back to .mfa)

Hold left / right to scroll around for a few minutes (or close and restart) to see random frame drops/skips.

PLEASE HELP this problem is driving me crazy!

 
www.paulinthenet.de
www.gungirl2.com

xXBlazefirelpXx



Registered
  14/06/2010
Points
  45
9th October, 2011 at 15:09:28 -

I too have this problem, it frustrates me to high hell. Almost everything I try and run in MMF2 just has some serious framerate drops. (Usually down to 37/39FPS). It makes most of my projects unplayable when compiled into an exe because the problem is stuck to it in whatever form I choose.

 
-----------------------------------------------

Chris Burrows



Registered
  14/09/2002
Points
  2396

GOTW WINNER OCT. 2011
9th October, 2011 at 15:23:16 -

I don't think it's the framerate. For me, the framerate never drops below 58, even during the random skips.

It isn't your movement code because the same thing happens with the default 8 directional movement.
It isn't your the fact your parallaxing 5 layers at once because it still happens when you delete all layers but the one with the actives.
And it also isn't a whole bunch of other stuff I tried. No idea sorry

Although, I did build the game again from scratch with the same objects and did NOT experence the skips.. So not sure what is happening.

 
n/a

Rikus

Administrator
Crazy for News

Registered
  02/12/2001
Points
  500
9th October, 2011 at 17:39:23 -

Blue maybe send an email to clickteam directly and attach the example maybe it is a bug in mmf itself?

 
Be sure to follow us on the twitters for the latest and greatest: @dailyclick

UrbanMonk

BRING BACK MITCH

Registered
  07/07/2008
Points
  49614

Has Donated, Thank You!Little Pirate!ARGH SignKliktober Special Award TagPicture Me This Round 33 Winner!The Outlaw!VIP MemberHasslevania 2!I am an April FoolKitty
Picture Me This Round 32 Winner!Picture Me This Round 42 Winner!Picture Me This Round 44 Winner!Picture Me This Round 53 Winner!
9th October, 2011 at 20:21:41 -

It's because your monitors refresh rate doesn't match the games fps.

Turn on V-sync.
That fixed it for me.

 
n/a

GamesterXIII



Registered
  04/12/2008
Points
  1110

I am an April Fool
9th October, 2011 at 21:45:35 -

Delete the MFA.

 
n/a

Blue66



Registered
  24/05/2008
Points
  1186

GOTW JUNE 2010 WINNER!Hero of TimeVIP Member
10th October, 2011 at 01:22:22 -


Originally Posted by Rikus
Blue maybe send an email to clickteam directly and attach the example maybe it is a bug in mmf itself?



Thanks for the suggestion! Do you have the email adress from someone at Clickteam? I can't find any email adresses.


Originally Posted by . : UrbanMonk : .
It's because your monitors refresh rate doesn't match the games fps.

Turn on V-sync.
That fixed it for me.



My monitor works at 60hz also V-Sync does not fix it for me, I've tried.

Edited by Blue66

 
www.paulinthenet.de
www.gungirl2.com

nivram



Registered
  20/07/2006
Points
  171
10th October, 2011 at 03:33:23 -

jvance@clickteam.com

Marv

 
458 MMF2 & CTF 2.5 examples and games

http://www.castles-of-britain.com/mmf2examples.htm
   

Post Reply



 



Advertisement

Worth A Click