The Daily Click ::. Forums ::. Klik Coding Help ::. Application created by mmf2 is crashing
 

Post Reply  Post Oekaki 
 

Posted By Message

deb_J



Registered
  22/05/2015 17:52:15
Points
  10
22nd May, 2015 at 22/05/2015 17:57:08 -

Hello everyone. I am new here. New in mmf2 too. I have made a web browser with custom features like random UA and Referral. It restarts "Frame" every 1 minute. I noticed after ruining 2 3 hours without any problem, my application is crashing randomly.

I used "web control Object" for the browser. Can anyone please tell me how to stop it from being crashed or anyway to add an option that on crash it will restart itself?

Thank you.

 
Deb

UrbanMonk

BRING BACK MITCH

Registered
  07/07/2008
Points
  49614

Has Donated, Thank You!Little Pirate!ARGH SignKliktober Special Award TagPicture Me This Round 33 Winner!The Outlaw!VIP MemberHasslevania 2!I am an April FoolKitty
Picture Me This Round 32 Winner!Picture Me This Round 42 Winner!Picture Me This Round 44 Winner!Picture Me This Round 53 Winner!
1st June, 2015 at 01/06/2015 18:08:50 -

Sounds like the web control might have a leak or race condition. Check your memory usage in task manager after a few restarts. If you see it growing larger alert the extension creator. If you don't see anything unusual in the task manager then it could be any number of things. Either way alert the extension creator.

Also why do you need to restart the frame so much?

 
n/a

deb_J



Registered
  22/05/2015 17:52:15
Points
  10
2nd June, 2015 at 02/06/2015 05:55:15 -

ok..thank you for the reply. I will do that. Do you think it may be due to capabilities problem? Because I am running it on Server 2012 while the extension says it supports 2008?

 
Deb

UrbanMonk

BRING BACK MITCH

Registered
  07/07/2008
Points
  49614

Has Donated, Thank You!Little Pirate!ARGH SignKliktober Special Award TagPicture Me This Round 33 Winner!The Outlaw!VIP MemberHasslevania 2!I am an April FoolKitty
Picture Me This Round 32 Winner!Picture Me This Round 42 Winner!Picture Me This Round 44 Winner!Picture Me This Round 53 Winner!
5th June, 2015 at 05/06/2015 17:44:00 -

I doubt running it on server 2012 would cause that issue. You'd probably have the same issue on any operating system.

You didn't answer my question though. Why are you restarting the frame? If you tell me what you're trying to do I might be able to offer you an alternative solution.

 
n/a

deb_J



Registered
  22/05/2015 17:52:15
Points
  10
8th June, 2015 at 08/06/2015 08:08:16 -

Ohh...I am sorry I forgot to write that ) I made a browser ...I was thinking browser extension might be the one who is causing problem...so if it gives error and on error if frame get restarted, I might avoid the crashing problem. so I added restart the frame !



 
Deb
   

Post Reply



 



Advertisement

Worth A Click