The Daily Click ::. Forums ::. Klik Coding Help ::. Disappearing Actives
 

Post Reply  Post Oekaki 
 

Posted By Message

Warwolf90300



Registered
  26/06/2016 11:25:12
Points
  4
26th June, 2016 at 26/06/2016 11:35:04 -

So every time I work on project I always have fun until well.. Actives disappear. The game is going fine and halfway through all actives disappear but everything else stays. I set the object limit to 10000 so it should be good I guess. I don't know i'm new to TGF2 and have a basic knowledge of the program. I just wish I could get a game done but this error happens everytime, hope someone can help me out.

 
n/a

AndyUK

Mascot Maniac

Registered
  01/08/2002
Points
  14560

Game of the Week WinnerSecond GOTW AwardHas Donated, Thank You!VIP Member
28th June, 2016 at 28/06/2016 05:13:59 -

It'd have to be a complete stab in the dark unless we can see something you've been working on. Obviously they shouldn't just start disappearing.
Just a guess though, do you realise you have to set the active object limit separately for every frame?

 
.

Warwolf90300



Registered
  26/06/2016 11:25:12
Points
  4
29th June, 2016 at 29/06/2016 00:29:37 -

Yes I have set the limit for every frame but the actives still disappear. I do have screenshots of what i've been working on and the bug right here http://imgur.com/a/DcJN1. (I know it looks HORRIBLE but it's just a test application just for me to screw around with ai and animations.)

P.S: Don't click the link, just copy and paste it into the search bar at the top of the browser because imgur is awesome and likes to direct the link to their front page.

 
n/a

Pan-tosser



Registered
  24/10/2008
Points
  520

Has Donated, Thank You!
29th June, 2016 at 29/06/2016 02:56:48 -

Are you sure he is gone and not hiding behind another object, or falling off the screen so fast you didn't see it.

 
https://www.facebook.com/nathon.brown.7

Warwolf90300



Registered
  26/06/2016 11:25:12
Points
  4
29th June, 2016 at 29/06/2016 03:15:10 -

I'm pretty sure nothing is falling because i set the floor actives to be static, and if the actives were behind the quick backdrop the floor would still be there since the backdrop doesn't stretch to the floor active at the bottom.

 
n/a

AndyUK

Mascot Maniac

Registered
  01/08/2002
Points
  14560

Game of the Week WinnerSecond GOTW AwardHas Donated, Thank You!VIP Member
29th June, 2016 at 29/06/2016 06:24:52 -

oh right they don't disappear. They just don't appear.

There is a check box on all active objects. Click on an active object and then click on the runtime tab on the properties window. Make sure 'create at start' is ticked on all different actives.

Also make sure your animation frames have something in stopped. (If you change the animation to 'disappearing' it will get destroyed after the animation plays, so check that too)

Also check you aren't setting the transparency to 100% or something.

There really could be a dozen different reasons for this...

 
.

Warwolf90300



Registered
  26/06/2016 11:25:12
Points
  4
29th June, 2016 at 29/06/2016 09:34:06 -

Thanks! Yeah I kind of worded that poorly but now the actives actually appear now so thanks for your help!

 
n/a

Pan-tosser



Registered
  24/10/2008
Points
  520

Has Donated, Thank You!
29th June, 2016 at 29/06/2016 23:21:28 -

glad it worked out. But you might want to keep an eye on that build of your game.

When strange stuff like that happens to me. I copy my code over to a new game file, cause sometimes files can get corrupted and do odd stuff.

 
https://www.facebook.com/nathon.brown.7
   

Post Reply



 



Advertisement

Worth A Click